Generator light came on then off

This area is for posting questions/information concerning 1955-57 year Thunderbirds NO FOR SALE POSTINGS

Moderator: Joe Johnston

Post Reply
cscolastico
Posts: 80
Joined: Thu Feb 16, 2017 12:21 am

Generator light came on then off

Post by cscolastico » Thu Oct 26, 2017 1:28 am

Greetings all. Took my 57 for a ride tonight. Drove about 35 mile to a party. Car sat for about 3 hours. On may way home the generator light came on for about 5 to 10 seconds then off again. I was driving about 45 mph when it happened , with the tach somewhere between 1000 and 2000 rpm. It did not come on for the remainder of my trip home - about 45 minutes , mostly highway cruising over 2000 rpms. But I did notice that when coming to some stop lights and idling in gear, the gen light would come on steady, whereas before it would just flicker a bit as the rpms bounced around 500 or so.. With a little gas,raising the rpms up a bit, the light would go out. I changed the regulator a few months ago, but I have read from this site that some of the newer regulators may not be very good. Anyway, any ideas on what would cause the gen light to come on at highway speed, then go out? (Sticky contact in regulator?) And the to come on at a higher rpm than usual?

As always, thanks for you responses.

User avatar
paul2748
Posts: 960
Joined: Sun Mar 15, 2009 12:23 am
Location: Northeastern New Jersey

Re: Generator light came on then off

Post by paul2748 » Thu Oct 26, 2017 8:34 pm

Double check all your connections
1956 Fiesta Red 312
1954 Ford Victoria 312
1948 Ford Convertible Street Rod 302

cscolastico
Posts: 80
Joined: Thu Feb 16, 2017 12:21 am

Re: Generator light came on then off

Post by cscolastico » Fri Oct 27, 2017 1:09 pm

Thanks Paul. Think I'm going to do that this morning

bammer
Posts: 31
Joined: Sat May 06, 2017 8:16 pm

Re: Generator light came on then off

Post by bammer » Tue Nov 14, 2017 9:20 pm

loose fan belt?

Post Reply