Hydroboost Installation - 1962

This area is for posting questions/information concerning 1961-63 year Thunderbirds NO FOR SALE POSTINGS

Moderator: Wklink

User avatar
ozbird
Posts: 878
Joined: Tue Aug 07, 2007 4:45 am
Location: Australia

Re: Hydroboost Installation - 1962

Post by ozbird » Mon Apr 11, 2016 2:30 am

Hi Guys,

been a while since I've posted about my conversion, still stopping like a champ but on checking the rubber brake lines I found both left and right had bubbles that did not look too flash. The rear line seemed ok but I decided to replace all 3 with braided lines, DOT approved and very fancy...yes not cheap!

Here are some images for any interested folk out there - I tell you what, bleeding these suckers is for the birds! The copper sealing washers on the calipers would not seal and took a while to get that sorted and ended up using the old washers - but it still stops, not sure if any better or worse!

Graeme

Image

Image

Image
1962 Hardtop - in Melbourne, Australia

User avatar
novanutcase
Posts: 1817
Joined: Tue Nov 18, 2008 2:58 am

Re: Hydroboost Installation - 1962

Post by novanutcase » Tue Apr 12, 2016 4:24 pm

Those braided lines are sexy!!! \:D/

John
Professional Pic Whore

Image

crashchoate
Posts: 22
Joined: Mon Aug 20, 2018 10:01 pm

Re: Hydroboost Installation - 1962

Post by crashchoate » Wed Sep 12, 2018 2:54 pm

I know this is a old thread but I was hoping to figure out what you did for the power steering pump. Did you have to replace the pump with a different one. Do you know what the pressure the stock pump pressure is. I want to do this with a 64 and I believe that the pumps are the same.

User avatar
ozbird
Posts: 878
Joined: Tue Aug 07, 2007 4:45 am
Location: Australia

Re: Hydroboost Installation - 1962

Post by ozbird » Wed Sep 12, 2018 6:39 pm

No worries, did not replace anything, had no leaks or issues with stock pump.

If it was me I'd use your old pump too, if anything the later model would be better.

Graeme
1962 Hardtop - in Melbourne, Australia

crashchoate
Posts: 22
Joined: Mon Aug 20, 2018 10:01 pm

Re: Hydroboost Installation - 1962

Post by crashchoate » Wed Sep 12, 2018 10:53 pm

After you replaced the brake lines how is the performance of your brakes. I'm going to stick with the drums for a little while till funds are there for disc

User avatar
ozbird
Posts: 878
Joined: Tue Aug 07, 2007 4:45 am
Location: Australia

Re: Hydroboost Installation - 1962

Post by ozbird » Wed Sep 12, 2018 10:57 pm

Brakes excellent, not sure if drums all round will be better.
1962 Hardtop - in Melbourne, Australia

User avatar
RedBird64
Posts: 1533
Joined: Wed Oct 31, 2012 11:42 pm
Location: Bothell Wa.

Re: Hydroboost Installation - 1962

Post by RedBird64 » Thu Sep 20, 2018 8:44 pm

That is a sweet setup. I wonder if the Hydroboost's lines could just go in series between the steering gear and the windsheild wiper motor?
That would make for a clean setup.

Btw, what size bore is your MC?
1964 Coupe Wimbledon white/Rangoon Red w/black int. Owned for 41 years. It was my folks car before that (not orig owners). VTCI # 12013.

Post Reply